CLICK HERE FOR FREE BLOGGER TEMPLATES, LINK BUTTONS AND MORE! »

Sunday, 06 March 2011

Problems with lots sinking into the ground or raising the ground - SOLVED

Problems with lots sinking into the ground or raising the ground - SOLVED


Here is how I did it (If someone else wants to try it):


1. Open the game and go to the world that you would like to place this lot in.

2. Make sure you have the correct size lot available but don't place your lot yet.

3. Click on the lot and select the edit lot tool. Wait for the lot to load.

4. Once the blank lot is loaded do the following:


1. Enter the cheat space (Ctrl+Shift+C) and type testingcheatsenabled true press enter

2. Cheat space again and type constrainFloorElevation false press enter

3. Cheat space type setimportedterrainoffset {value} press enter (See note below about the {value} you have to add here)

4. Now reverse the cheat commands constrainFloorElevation true, testingcheatsenabled false, remember to press enter after each command

5. Go to edit town and place your lot

If all went well your lot should now be perfect!!!

ps The command setimportedterrainoffset {value} The value here can be diffrent from what I have used. I tried diffrent values until I got it to where it should be. If your lot is raised instead of sinking you can use a negative value for instance -3.

I hope this will help someone that is also having a similar problem.

11 comments:

  1. I'll have to try this. I was having a lot of problems with placing houses in Los Aniegos because any lot I'd place would sink several feet below the road. I was about to give up and just build my own lots, but all I can manage are rectangle box houses.

    ReplyDelete
  2. I know its been a few months, but thank you! My sinking lots had seriously begun to annoy me.

    ReplyDelete
  3. have attempted ur solution but still isnt workin i may be doin something wrong but cant work out what it is.

    ReplyDelete
  4. Thank you, thank you, thank you! This does totally work, you've helped me to save a 3-month-work!

    ReplyDelete
  5. Thank you all for the comments :)

    ReplyDelete
  6. Thank you so much! It was driving me INSANE but your guide help me get things back to normal thanks a bunch! xoxoxo Hugs :)

    ReplyDelete
  7. Thank you. It worked perfectly for me after only trying 2 values.

    ReplyDelete
  8. after you do the offset terrain cheat would you put a space between say -3 or is it no space between?

    ReplyDelete
  9. this helped alot. Thanks

    ReplyDelete
  10. Omg! this totally worked, TYVM!

    ReplyDelete
  11. Do not use the {brackets}. I used 0 (zero) to bring my lot to the level of the road. My command was:

    setimportedterrainoffset 0

    Super helpful, thank you for sharing! :)

    ReplyDelete

Thank you for leaving a comment :-)